使用widora_mode 设置wifi 后,怎么设置回网口上网?



  • 使用widora_mode client 设置模块连接上路由了,但想设置会网口连接上网如何?widora_mode router wifi 不连接了,但网口依旧获取不到IP


  • administrators

    运行widora_mode router后模式切不回去?
    贴一下network和wireless文件内容



  • network:

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd69:7db8:2f50::/48'

    config interface 'lan'
    option force_link '1'
    option macaddr '0c:ef:af:d0:77:e1'
    option type 'bridge'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option proto 'dhcp'
    option ifname 'eth0'

    config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

    config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0 6t'



  • wireless:

    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'CN'
    option hwmode '11g'
    option htmode 'HT40'
    option channel 'auto'
    option disabled '0'
    option linkit_mode 'apsta'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option ifname 'ra0'
    option ssid 'PIP-77E0'
    option encryption 'none'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option ifname 'apcli0'
    option led 'mediatek:orange:wifi'
    option encryption 'psk'
    option disabled '0'
    option network 'lan'


  • administrators

    试试把wan6部分的 dhcpv6修改为dhcp