请教下,有没有用widora-neo使用client或者repeater模式连接过不是192.168.1.x的AP



  • 最近想使用widora-neo做点小玩意,公司的路由器AP是172.16.xx.xx段的,使用widora-neo的client或者repeater模式连接AP的时候总是获取不到IP地址,用ap_client查看的时候已经连上AP了。请教下各位有没有碰到这样情况的,这个问题网上查了很多资料搞了几天也没搞定,请帮忙指导一下,谢谢。

    PS:以下文件是使用firstboot 后打开的。
    恢复出厂设置后连接路由器:
    root@zhvdata:/# widora_mode client zhvdata 07568607068
    [ 181.550000] br-lan: port 2(ra0) entered disabled state
    [ 181.590000] WLAN:STA 88:25:93:d0:6f:e7(dev:ra0 rate:65Mbps singnal:-18dBm) disconnect
    [ 182.120000] device ra0 left promiscuous mode
    [ 182.120000] br-lan: port 2(ra0) entered disabled state
    [ 182.640000] br-lan: port 1(eth0) entered disabled state
    [ 182.650000] device eth0 left promiscuous mode
    [ 182.660000] br-lan: port 1(eth0) entered disabled state
    [ 182.940000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    root@zhvdata:/# [ 185.070000] device eth0 entered promiscuous mode
    [ 185.070000] br-lan: port 1(eth0) entered forwarding state
    [ 185.080000] br-lan: port 1(eth0) entered forwarding state
    [ 187.080000] br-lan: port 1(eth0) entered forwarding state
    [ 188.090000] =====================================================
    [ 188.090000] Channel 1 : Busy Time = 19505, Skip Channel = FALSE
    [ 188.100000] Channel 2 : Busy Time = 20189, Skip Channel = FALSE
    [ 188.100000] Channel 3 : Busy Time = 15073, Skip Channel = FALSE
    [ 188.110000] Channel 4 : Busy Time = 42220, Skip Channel = FALSE
    [ 188.120000] Channel 5 : Busy Time = 30081, Skip Channel = FALSE
    [ 188.120000] Channel 6 : Busy Time = 28249, Skip Channel = FALSE
    [ 188.130000] Channel 7 : Busy Time = 31840, Skip Channel = FALSE
    [ 188.130000] Channel 8 : Busy Time = 15829, Skip Channel = FALSE
    [ 188.140000] Channel 9 : Busy Time = 13294, Skip Channel = FALSE
    [ 188.150000] Channel 10 : Busy Time = 24125, Skip Channel = FALSE
    [ 188.150000] Channel 11 : Busy Time = 21180, Skip Channel = FALSE
    [ 188.160000] Channel 12 : Busy Time = 27493, Skip Channel = TRUE
    [ 188.160000] Channel 13 : Busy Time = 16348, Skip Channel = TRUE
    [ 188.170000] =====================================================
    [ 188.180000] Rule 3 Channel Busy time value : Min Channel Busy ==> Select Channel 9
    [ 188.180000] Min Channel Busy = 13294
    [ 188.190000] BW = 20
    [ 188.220000] |--------------------------------------------------------|
    [ 188.220000] |------------Widora wifi driver--version:1.2-------------|
    [ 188.230000] |Copyright 2016-2017 by YuanChenMang. All rights reserved|
    [ 188.240000] | This Driver licensing-only runs on Widora! |
    [ 188.240000] | Found bug? Please contact widora@qq.com , thanks! |
    [ 188.250000] |--------------------------------------------------------|
    [ 190.100000] device ra0 entered promiscuous mode
    [ 190.100000] br-lan: port 2(ra0) entered forwarding state
    [ 190.110000] br-lan: port 2(ra0) entered forwarding state
    [ 192.110000] br-lan: port 2(ra0) entered forwarding state
    [ 196.040000] AP-Client probe response: SSID=zhvdata, BSSID=88:25:93:d0:6f:e7
    [ 196.050000] APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!

    root@zhvdata:/# ap_client
    ok
    root@zhvdata:/# ifconfig
    apcli0 Link encap:Ethernet HWaddr 0E:EF:AF:00:4A:28
    inet6 addr: fe80::cef:afff:fe00:4a28/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:684 (684.0 B) TX bytes:1752 (1.7 KiB)

    br-lan Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:29
    inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::eef:afff:fed0:4a29/64 Scope:Link
    inet6 addr: fd82:d83:c640::1/60 Scope:Global
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:5361 (5.2 KiB)

    eth0 Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:28
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:239 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:45347 (44.2 KiB)
    Interrupt:5

    eth0.2 Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:28
    inet6 addr: fe80::eef:afff:fed0:4a28/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:3044 (2.9 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:240 errors:0 dropped:0 overruns:0 frame:0
    TX packets:240 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:16320 (15.9 KiB) TX bytes:16320 (15.9 KiB)

    ra0 Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:28
    inet6 addr: fe80::eef:afff:fed0:4a28/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:6
    四个配置文件如下:
    root@zhvdata:/# cat /etc/config/network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd82:0d83:c640::/48'

    config interface 'lan'
    option force_link '1'
    option macaddr '0c:ef:af:d0:4a:29'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'eth0'

    config interface 'wan'
    option force_link '1'
    option macaddr '0c:ef:af:d0:4a:28'
    option proto 'dhcp'
    option ifname 'apcli0'

    config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

    config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0 6t'
    root@zhvdata:/# cat /etc/config/wireless

    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'CN'
    option hwmode '11bgn'
    option htmode 'HT20'
    option channel 'auto'
    option disabled '0'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option ifname 'ra0'
    option ssid 'zhvdata-4A28'
    option encryption 'none'
    option hidden '1'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option network 'wan'
    option ifname 'apcli0'
    option encryption 'psk'
    option ssid 'zhvdata'
    option key '07568607068'
    option disabled '0'
    root@zhvdata:/# cat /etc/config/firewall
    config defaults
    option syn_flood 1
    option input ACCEPT
    option output ACCEPT
    option forward REJECT

    Uncomment this line to disable ipv6 rules

    option disable_ipv6 1

    config zone
    option name lan
    list network 'lan'
    option input ACCEPT
    option output ACCEPT
    option forward ACCEPT

    config zone
    option name wan
    list network 'wan'
    list network 'wan6'
    option input REJECT
    option output ACCEPT
    option forward REJECT
    option masq 1
    option mtu_fix 1

    config forwarding
    option src lan
    option dest wan

    We need to accept udp packets on port 68,

    see https://dev.openwrt.org/ticket/4108

    config rule
    option name Allow-DHCP-Renew
    option src wan
    option proto udp
    option dest_port 68
    option target ACCEPT
    option family ipv4

    Allow IPv4 ping

    config rule
    option name Allow-Ping
    option src wan
    option proto icmp
    option icmp_type echo-request
    option family ipv4
    option target ACCEPT

    config rule
    option name Allow-IGMP
    option src wan
    option proto igmp
    option family ipv4
    option target ACCEPT

    Allow DHCPv6 replies

    see https://dev.openwrt.org/ticket/10381

    config rule
    option name Allow-DHCPv6
    option src wan
    option proto udp
    option src_ip fe80::/10
    option src_port 547
    option dest_ip fe80::/10
    option dest_port 546
    option family ipv6
    option target ACCEPT

    config rule
    option name Allow-MLD
    option src wan
    option proto icmp
    option src_ip fe80::/10
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family ipv6
    option target ACCEPT

    Allow essential incoming IPv6 ICMP traffic

    config rule
    option name Allow-ICMPv6-Input
    option src wan
    option proto icmp
    list icmp_type echo-request
    list icmp_type echo-reply
    list icmp_type destination-unreachable
    list icmp_type packet-too-big
    list icmp_type time-exceeded
    list icmp_type bad-header
    list icmp_type unknown-header-type
    list icmp_type router-solicitation
    list icmp_type neighbour-solicitation
    list icmp_type router-advertisement
    list icmp_type neighbour-advertisement
    option limit 1000/sec
    option family ipv6
    option target ACCEPT

    Allow essential forwarded IPv6 ICMP traffic

    config rule
    option name Allow-ICMPv6-Forward
    option src wan
    option dest *
    option proto icmp
    list icmp_type echo-request
    list icmp_type echo-reply
    list icmp_type destination-unreachable
    list icmp_type packet-too-big
    list icmp_type time-exceeded
    list icmp_type bad-header
    list icmp_type unknown-header-type
    option limit 1000/sec
    option family ipv6
    option target ACCEPT

    include a file with users custom iptables rules

    config include
    option path /etc/firewall.user

    EXAMPLE CONFIG SECTIONS

    do not allow a specific ip to access wan

    #config rule

    option src lan

    option src_ip 192.168.45.2

    option dest wan

    option proto tcp

    option target REJECT

    block a specific mac on wan

    #config rule

    option dest wan

    option src_mac 00:11:22:33:44:66

    option target REJECT

    block incoming ICMP traffic on a zone

    #config rule

    option src lan

    option proto ICMP

    option target DROP

    port redirect port coming in on wan to lan

    #config redirect

    option src wan

    option src_dport 80

    option dest lan

    option dest_ip 192.168.16.235

    option dest_port 80

    option proto tcp

    port redirect of remapped ssh port (22001) on wan

    #config redirect

    option src wan

    option src_dport 22001

    option dest lan

    option dest_port 22

    option proto tcp

    allow IPsec/ESP and ISAKMP passthrough

    config rule
    option src wan
    option dest lan
    option proto esp
    option target ACCEPT

    config rule
    option src wan
    option dest lan
    option dest_port 500
    option proto udp
    option target ACCEPT

    FULL CONFIG SECTIONS

    #config rule

    option src lan

    option src_ip 192.168.45.2

    option src_mac 00:11:22:33:44:55

    option src_port 80

    option dest wan

    option dest_ip 194.25.2.129

    option dest_port 120

    option proto tcp

    option target REJECT

    #config redirect

    option src lan

    option src_ip 192.168.45.2

    option src_mac 00:11:22:33:44:55

    option src_port 1024

    option src_dport 80

    option dest_ip 194.25.2.129

    option dest_port 120

    option proto tcp

    root@zhvdata:/# cat /etc/config/dhcp

    config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option localservice '1'

    config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv6 'server'
    option ra 'server'
    option ignore '0'

    config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

    config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'



  • 这个是连接另外一个路由器的(192.168.1.x段的):
    root@zhvdata:/# widora_mode client zhvdata2 07568607068
    [ 931.860000] br-lan: port 2(ra0) entered disabled state
    [ 931.900000] WLAN:STA 88:25:93:d0:6f:e7(dev:ra0 rate:65Mbps singnal:-18dBm) disconnect
    [ 932.430000] device ra0 left promiscuous mode
    [ 932.430000] br-lan: port 2(ra0) entered disabled state
    [ 932.960000] br-lan: port 1(eth0) entered disabled state
    [ 932.970000] device eth0 left promiscuous mode
    [ 932.980000] br-lan: port 1(eth0) entered disabled state
    [ 933.190000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    root@zhvdata:/# [ 935.350000] device eth0 entered promiscuous mode
    [ 935.350000] br-lan: port 1(eth0) entered forwarding state
    [ 935.360000] br-lan: port 1(eth0) entered forwarding state
    [ 937.360000] br-lan: port 1(eth0) entered forwarding state
    [ 938.370000] =====================================================
    [ 938.370000] Channel 1 : Busy Time = 18972, Skip Channel = FALSE
    [ 938.380000] Channel 2 : Busy Time = 13910, Skip Channel = FALSE
    [ 938.380000] Channel 3 : Busy Time = 15523, Skip Channel = FALSE
    [ 938.390000] Channel 4 : Busy Time = 13734, Skip Channel = FALSE
    [ 938.400000] Channel 5 : Busy Time = 29972, Skip Channel = FALSE
    [ 938.400000] Channel 6 : Busy Time = 19887, Skip Channel = FALSE
    [ 938.410000] Channel 7 : Busy Time = 22884, Skip Channel = FALSE
    [ 938.410000] Channel 8 : Busy Time = 18131, Skip Channel = FALSE
    [ 938.420000] Channel 9 : Busy Time = 13457, Skip Channel = FALSE
    [ 938.430000] Channel 10 : Busy Time = 19871, Skip Channel = FALSE
    [ 938.430000] Channel 11 : Busy Time = 22112, Skip Channel = FALSE
    [ 938.440000] Channel 12 : Busy Time = 20557, Skip Channel = TRUE
    [ 938.440000] Channel 13 : Busy Time = 14915, Skip Channel = TRUE
    [ 938.450000] =====================================================
    [ 938.460000] Rule 3 Channel Busy time value : Min Channel Busy ==> Select Channel 9
    [ 938.460000] Min Channel Busy = 13457
    [ 938.470000] BW = 20
    [ 938.500000] |--------------------------------------------------------|
    [ 938.500000] |------------Widora wifi driver--version:1.2-------------|
    [ 938.510000] |Copyright 2016-2017 by YuanChenMang. All rights reserved|
    [ 938.520000] | This Driver licensing-only runs on Widora! |
    [ 938.520000] | Found bug? Please contact widora@qq.com , thanks! |
    [ 938.530000] |--------------------------------------------------------|
    [ 940.380000] device ra0 entered promiscuous mode
    [ 940.390000] br-lan: port 2(ra0) entered forwarding state
    [ 940.390000] br-lan: port 2(ra0) entered forwarding state
    [ 942.390000] br-lan: port 2(ra0) entered forwarding state
    [ 946.330000] AP-Client probe response: SSID=zhvdata, BSSID=00:bd:82:41:4a:bd
    [ 946.340000] APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(4)=TKIP!

    root@zhvdata:/# ifconfig
    apcli0 Link encap:Ethernet HWaddr 0E:EF:AF:00:4A:28
    inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::cef:afff:fe00:4a28/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:160 errors:0 dropped:0 overruns:0 frame:0
    TX packets:262 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:21771 (21.2 KiB) TX bytes:83578 (81.6 KiB)

    br-lan Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:29
    inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::eef:afff:fed0:4a29/64 Scope:Link
    inet6 addr: fd82:d83:c640::1/60 Scope:Global
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:5779 (5.6 KiB)

    eth0 Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:28
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:318 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:56187 (54.8 KiB)
    Interrupt:5

    eth0.2 Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:28
    inet6 addr: fe80::eef:afff:fed0:4a28/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:2957 (2.8 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:1344 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1344 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:91392 (89.2 KiB) TX bytes:91392 (89.2 KiB)

    ra0 Link encap:Ethernet HWaddr 0C:EF:AF:D0:4A:28
    inet6 addr: fe80::eef:afff:fed0:4a28/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:6

    root@zhvdata:/# ping www.baidu.com
    ping: bad address 'www.baidu.com'
    root@zhvdata:/# ping 120.25.197.210
    PING 120.25.197.210 (120.25.197.210): 56 data bytes
    64 bytes from 120.25.197.210: seq=0 ttl=116 time=17.465 ms
    64 bytes from 120.25.197.210: seq=1 ttl=116 time=21.330 ms
    ^C
    --- 120.25.197.210 ping statistics ---
    2 packets transmitted, 2 packets received, 0% packet loss
    round-trip min/avg/max = 17.465/19.397/21.330 ms
    root@zhvdata:/#


  • administrators

    默认源码是不限制网段的。
    建议测试一下你能连上的这个WI-FI,改个网段试试



  • 明天去公司把公司路由器改个网段试试,我试了下家里的改了网段为172的是没问题的。有点诡异。


  • administrators

    @mrxsean 或许是你们公司的对于新设备来说,地址池满了?



  • 不会,人少的时候也是一样的。我都在路由器看到分配地址了,但是在neo上就是看不到。所以一直在折腾,然后我切换到另外一个192的网络马上就ok了。所以一直很纳闷。。明天试试改网段,再到这里来反馈下结果。



  • 换了一个网段192.168.2.x,还是不行,好奇怪,看来跟这个路由器有关系,但是我们电脑还有其它wifi设备都是正常的。


  • administrators

    @mrxsean 有个别用户碰到过这种路由器。可能兼容性有些问题。