can't ssh into neo



  • Hello, I'm new here.
    I upgraded a few days ago to firmware 0.1.7. I couldn't get wifi to work. I don't know why, but while trying I did something wrong and I can't ssh to the NEO anymore, I don't get an IP also. When I connect the NEO to my router it gets an IP, when i browse tot the IP I come to a site with unknow symbols so I can't read it. Is there a way to reset the NEO by hardware? Pushing the rest button only reboots the device.


  • administrators

    Hello,

    1. the default firmware's Wi-Fi set page is written in chinese by me,not luci.
    2. you can run "opkg install luci" to change it.
    3. get the board IP, you can use the "ifconfig br-lan" command.
    4. if SSH not login, you can console Widora by serial , 115200,8,N,1, refer to : http://docs.widora.io/neo-start
    5. if problem, just post here, I will resolve. 🙂


  • Thanks Mango,

    OK baud rate is 115200. I ddin't find it in the wiki, sorry for that, but it's difficult if you see only weird symbols.
    I don't get wifi to work. In /etc/config/wireless the device is mt7688 but the firmware says this device doesn't exist.


  • administrators

    Ref the docs : http://docs.widora.io
    if you want connect to other APs, just use command like : widora_mode repeater ssid key


  • administrators

    @roel said in can't ssh into neo:

    In /etc/config/wireless the device is mt7688 but the firmware says this device doesn't exist.
    the wireless is
    0_1494482881970_2017-05-11 下午2.07.27.png



  • OK radio0 make sense. I will adjust the config. I already thought that was strange.



  • BTW I already tried the widora_mode repeater ssid key, but I got a error that MT7628 doesn't exist (or something like that).
    How do you use that command? Do you have to replace ssid with the ssid to connect to and key with the password? Don't you have to define the device, for example

    widora_mode repeater radio ssid home key 1234578
    or
    widora mode repeater home 1234578

    or is the command interactive and does it ask which ssid and pasword.

    I already tried the command in a few variations but only get the error about the missing mt7628 device.

    Thanks for the support, I appreciate your work.


  • administrators

    about "MT7628 doesn't exist",can you post a log here ?
    for example:
    my ssid is ABC, key is 12345678, just use command : widora_mode repeater ABC 12345678
    then, check if or not link,you can use: ap_client,
    checkout the return is ok or no.



  • Mango,

    I managed to get in the NEO again and did a 'firstboot' to reset everything. First thin i noticed is that the IP is now 192.168.1.1 it was 192.168.99.1 before the firstboot. Now everything works without problem. The widora_mode command works without error message. I checked /etc/config/wireless and this is now a compleet different configuration with indeed radio0 as wifi-device. Something strange happened here.


  • administrators

    Is it possible for me to operate on the board? Changing the stuff is actually in the overlay partition. Execute firstboot or jffs2reset -y will be restored as ever.
    But I'm not sure if it's the latest firmware, see here: github.com/widora/openwrt_widora , The latest firmware is 0.1.7(chaos calmer)