新固件,0.1.7RC2,期待大家测试反馈


  • administrators

    还没有修改版本号,基于0.1.6。在0.1.6基础上修改了wifi驱动。

    0_1489233736033_openwrt-ramips-mt7688-Widora-0.1.7-RC1.bin

    新增aac命令,运行后进入配网状态,等待手机airkissdebuger或者微信扫二维码,配网结束后命令退出。是否成功连接可以使用ap_client命令查看。连接回ok,未连接回no。

    配网二维码:
    0_1489233470190_IMG_1049.PNG

    整个板子的工作状态由命令widora_mode设置,可以自行设置如下命令:

    设置板子工作模式的命令

    $ widora_mode
    
    MODE REPEATER CLIENT ROUTER PPPOE
    LAN eth0 ap apcli0 eth0 ap ap
    WAN apcli0 eth0
    "widora_mode repeater" or "widora_mode repeater ssid key"
    "widora_mode client" or "widora_mode client ssid key"
    "widora_mode router"
    "widora_mode pppoe" or "widora_mode pppoe name key"
    
    目前web配置界面暂未修复

  • administrators

    更新RC2,修复了WebUI的一些小问题。
    0_1489278449916_openwrt-mt7688-Widora-0.1.7RC2.bin
    刷机方案使用Uboot的WEB更新:http://wiki.widora.io/doku.php?id=zh:webupdate



  • 你好,我下载0_1489278449916_openwrt-mt7688-Widora-0.1.7RC2.bin进行了一个小测试,

    1. 使用connect2ap命令连接路由器,选择四款路由器一次进行连接,都可以连接上;
      2.ap连接测试,发现当将/etc/config/wireless中的ap设置上加密方式和密码,然后重启固件,wireless中的配置会多生成一遍。如下
      root@Widora:/# cat /etc/config/wireless

    nfig wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'CN'
    option hwmode '11g'
    option htmode 'HT40'
    option channel 'auto'
    option disabled '0'
    option linkit_mode 'sta'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option ifname 'ra0'
    option ssid 'Widora-1256'
    option encryption 'psk-mixed'
    option key '12345678'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option network 'wan'
    option ifname 'apcli0'
    option led 'mediatek:orange:wifi'
    option encryption 'psk'
    option disabled '0'
    option ssid 'cisco_test01'
    option key '1234567890'

    config wifi-device radio0
    option type ralink
    option variant mt7628
    option country CN
    option hwmode 11g
    option htmode HT40
    option channel auto
    option disabled 0
    option linkit_mode ap

    config wifi-iface ap
    option device radio0
    option mode ap
    option network lan
    option ifname ra0
    option ssid Widora-1256
    option encryption none

    config wifi-iface sta
    option device radio0
    option mode sta
    option network wan
    option ifname apcli0
    option led mediatek:orange:wifi
    option ssid UplinkAp
    option key SecretKey
    option encryption psk
    上述现象是我使用vi手动修改wireless配置文件时出现的,当我将配置文件中修改的上半部分删除后,使用web配置无线网络和ap的密码后,这个现象就没有再复现了,而且使用电脑连接ap和上网都正常了。
    另外请教一个问题,我想设置成ap+sta的模式,是不是应该将 option linkit_mode 项设成‘apsta’,



  • 此回复已被删除!


  • 我做ap测试时发现这样一个问题:
    用B设备连接A设备的ap,如果A只连网线的话,A可以上网,B却无法上网,如果A同时连接网线和wifi,B则可以正常上网。我是将A设备设置成了双wan口+ap的模式,下面是我的配置文件,请指教:
    root@Widora:/# cat /etc/config/wireless
    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'CN'
    option hwmode '11g'
    option htmode 'HT40'
    option channel 'auto'
    option disabled '0'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option ifname 'ra0'
    option ssid 'Widora-E101'
    option encryption 'psk-mixed'
    option key '12345678'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option network 'wan'
    option ifname 'apcli0'
    option led 'mediatek:orange:wifi'
    option encryption 'psk'
    option disabled '1'
    option ssid 'cisco_test01'
    option key '1234567890'

    root@Widora:/# cat /etc/config/network
    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
    config globals 'globals'
    option ula_prefix 'fdd2:0de4:8b13::/48'

    config interface 'lan'
    option force_link '1'
    option macaddr '0c:ef:af:cf:e1:03'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'br-lan'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '0'

    config interface 'wan'
    option ifname 'apcli0'
    option proto 'dhcp'

    config interface 'wan0'
    option ifname 'eth0'
    option proto 'dhcp


  • administrators

    @lx 你误删了linkit_mode那行



  • @mango 关于linkit_mode这个option我不是很明白,ap+sta模式时,linkit_mode 设成sta时ap和sta的接口都可以正常通信,那apsta是什么模式时使用呢?


  • administrators

    @lx 其实脚本里处理的不是很严格,稍后我考虑去掉这个状态标识



  • @mango 谢谢你的回复,期待新版本的更新


  • administrators